WPセキュリティ診断脆弱性データ 2026年10月29日 時点 フォローして新着情報を受け取る

CVE-2026-111828

Classified Listing – AI-Powered Classified ads & Business Directory に報告された脆弱性

高深刻度
8.8CVSS
6.2.0修正されたバージョン
0.2%30日以内に悪用される確率

今後30日以内に悪用される確率は 0.2% と推定されています(EPSS)。 現時点で活発な悪用は観測されていませんが、修正版が出ている場合は更新を推奨します。

概要

The Classified Listing – AI-Powered Classified ads & Business Directory plugin for WordPress is vulnerable to Code Injection in all versions up to, and including, 6.1.5. This is due to an inverted condition in the radio/select field type validation (`!is_array` instead of `is_array`) that caused the allowlist check to be skipped for every well-formed options array, and a `wp_kses_post()` call whose return value was discarded, together allowing arbitrary values to be stored in plugin settings that are later written to static PHP configuration files. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary PHP code into plugin-generated static files, allowing execution of malicious code on the server. The attacker must have access to an AJAX settings endpoint lacking a sufficient capability check; a missing authentication guard (one of the two auth_check additions in this release) allowed Subscriber-level users to reach the settings save handler.

CWE: CWE-94 / 公開 2026年10月19日 / 最終更新 2026年10月28日

影響を受けるバージョン

対処方法

Classified Listing – AI-Powered Classified ads & Business Directory を 6.2.0 以降に更新してください。これで本脆弱性は解消します。

提供元の推奨: Update to version 6.2.0, or a newer patched version

Classified Listing – AI-Powered Classified ads & Business Directory の他の脆弱性を見る →

あなたのサイトは大丈夫ですか?

URLを入力するだけで、実際に使われているプラグインを検出し、 このデータベースと突き合わせて既知の脆弱性が残っていないかを確認できます。登録不要・無料です。

30秒で無料診断する

参照

この脆弱性情報の一部は Wordfence Intelligence から取得しています。 原本: https://www.wordfence.com/threat-intel/vulnerabilities/id/9cd8338c-9987-4a7b-bd10-757a2595aaad

Copyright 2012-2026 Defiant Inc. / ライセンス全文