WPセキュリティ診断脆弱性データ 2026年10月28日 時点 フォローして新着情報を受け取る

CVE-2026-111120

VikRentCar Car Rental Management System に報告された脆弱性

高深刻度
8.8CVSS
1.4.9修正されたバージョン
—30日以内に悪用される確率

概要

The VikRentCar Car Rental Management System plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.8. This is due to missing or incorrect nonce validation on the condtext_update_tmpl function. This makes it possible for unauthenticated attackers to write arbitrary PHP code to the plugin's executable template files such as site/helpers/email_tmpl.php, which are later include()d by loadEmailTemplate() and loadPdfTemplate(), achieving remote code execution on the server via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The injected PHP payload bypasses sanitization because the plugin's own __PHP_OPEN__/__PHP_CLOSE__ placeholder expansion and cleanPHPSourceCode() logic explicitly reverse both sanitize_text_field filtering and saveHTML() HTML-encoding, restoring a literal <?php...?> payload to live PHP before it is written to disk. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

CWE: CWE-352 / 公開 2026年10月27日 / 最終更新 2026年10月27日

影響を受けるバージョン

対処方法

VikRentCar Car Rental Management System を 1.4.9 以降に更新してください。これで本脆弱性は解消します。

提供元の推奨: Update to version 1.4.9, or a newer patched version

VikRentCar Car Rental Management System の他の脆弱性を見る →

あなたのサイトは大丈夫ですか?

URLを入力するだけで、実際に使われているプラグインを検出し、 このデータベースと突き合わせて既知の脆弱性が残っていないかを確認できます。登録不要・無料です。

30秒で無料診断する

参照

この脆弱性情報の一部は Wordfence Intelligence から取得しています。 原本: https://www.wordfence.com/threat-intel/vulnerabilities/id/36f84246-6658-407a-88dd-4b99a784e682

Copyright 2012-2026 Defiant Inc. / ライセンス全文