WPセキュリティ診断脆弱性データ 2026年10月30日 時点 フォローして新着情報を受け取る

CVE-2026-104368

Export and Import Users and Customers に報告された脆弱性

高深刻度
8.8CVSS
2.7.6修正されたバージョン
—30日以内に悪用される確率

概要

The Export and Import Users and Customers plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.7.5 via the plugin's own export and re-import workflow. The vulnerability exists because of a CSV escape-character mismatch between the exporter and the importer: class-csvwriter.php writes cells with fputcsv() using PHP's default backslash (\) escape character, while class-csvreader.php parses the same file with fgetcsv() using a double-quote (") as the escape character. As a result, a crafted value stored in a Subscriber's Biographical Info field — containing a backslash-quote sequence followed by a newline — is written as a single quoted CSV field but parsed back as two separate rows on import. The injected second row is then processed by hf_create_customer() as a new user record whose user_login, user_pass, user_email, and role are entirely attacker-controlled, allowing the creation of an arbitrary Administrator account. This makes it possible for authenticated attackers with Subscriber-level access and above to escalate their privileges to Administrator.

CWE: CWE-116 / 公開 2026年10月29日 / 最終更新 2026年10月29日

影響を受けるバージョン

対処方法

Export and Import Users and Customers を 2.7.6 以降に更新してください。これで本脆弱性は解消します。

提供元の推奨: Update to version 2.7.6, or a newer patched version

Export and Import Users and Customers の他の脆弱性を見る →

あなたのサイトは大丈夫ですか?

URLを入力するだけで、実際に使われているプラグインを検出し、 このデータベースと突き合わせて既知の脆弱性が残っていないかを確認できます。登録不要・無料です。

30秒で無料診断する

参照

この脆弱性情報の一部は Wordfence Intelligence から取得しています。 原本: https://www.wordfence.com/threat-intel/vulnerabilities/id/4d358e43-f193-42fd-b49a-1b2a943183f2

Copyright 2012-2026 Defiant Inc. / ライセンス全文