Advanced Custom Fields: Extended に脆弱性 — CVE-2026-2839
いま何をすべきか
Advanced Custom Fields: Extended を 0.9.2.8 以降に更新してください。
影響を受けるバージョン
- 0.9.2.7 以下のすべて
対象: プラグイン「Advanced Custom Fields: Extended」(acf-extended)
何が起きるのか
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.
ここから先の選択肢
1. 自分たちで対応する
更新の手順、バックアップの取り方、壊れたときの戻し方をまとめています。
2. いまの制作会社・保守業者に頼む
Advanced Custom Fields: Extended を使っているかどうかを含めて確認を依頼してください。 無料診断を実行すると、そのまま渡せる依頼文を作れます。
3. 相談先がない・自分では難しい
連絡が取れる相手がいない、管理画面に入れない、侵入された疑いがある。 そうした場合はご相談ください。